CSS Navigation mit Dropdown

In diesem Artikel schauen wir uns mal an, wie wir eine ansehnliches Menü mit CSS hinbekommen. Dafür brauchen wir nur ein wenig HTML und CSS. Als erstes erstellen wir uns unsere HTML Datei, in der wir unser Menü erstellen.


//index.html
<div class="navigation">
 <ul>
  <li><a href="#">Startseite</a>
   <ul>
    <li><a href="#">News</a></li>
    <li><a href="#">Informationen</a></li>
    <li><a href="#">Sonstiges</a></li>
   </ul>
  </li>
  <li><a href="#">Kategorien</a>
   <ul>
    <li><a href="#">Sub-1</a></li>
    <li><a href="#">Sub-2</a></li>
    <li><a href="#">Sub-3</a></li>
    <li><a href="#">Sub-4</a></li>
    <li><a href="#">Sub-5</a></li>
   </ul>
  </li>
  <li><a href="#">Kontakt</a>
   <ul>
    <li><a href="#">Kontaktformular</a></li>
    <li><a href="#">Facebook</a></li>
    <li><a href="#">Twitter</a></li>
    <li><a href="#">Google+</a></li>
    <li><a href="#">Pinterest</a></li>
   </ul>
  </li>
  <li><a href="#">Blog</a></li>
  <li><a href="#">Impressum</a></li>
 </ul>
</div>

Das war der Teil mit dem HTML. Wenn wir uns das Ganze nun anschauen würden, wäre nur ein Listenmenü zu sehen. Deswegen kommen wir nun an das wichtigste, die Formatierung mit CSS.


/* layout.css */
.navigation {
 background-color: #444;
 overflow: hidden;
 border-right: 1px solid #333;
 font-family:verdana;
}
 
.navigation li {
 list-style: none;
 float:left;
 padding: 5px 8px 5px 8px;
 height: 30px;
 background-color: #444;
 border:1px solid #333;
}
 
.navigation li ul {
 display: none;
 width: 220px;
 margin: 10px 0px 0px -50px;
}
 
.navigation li a {
 display: block;
 color: #fff;
}
 
.navigation li a:hover{
 text-decoration: none;
}
 
.navigation li:hover > ul{
 display: block;
 position: absolute;
}
 
.navigation li:hover li{
 float: none;
 border-left:3px solid transparent;
}
 
.navigation li li:hover {
 background-color: #666;
 border-left:3px solid #82b965;
}
 
.navigation li li:hover a {
 color:#82b965;
}

Wenn wir nun alles richtig gemacht haben, dann sollte das Ergebnis so aussehen, wie im folgenden Screenshot.

Ich hoffe, ich konnte mit meinem Artikel ein wenig helfen.

Summe-Funktion in Excel

Einer der häufigsten Funktionen, die man in Excel verwendet, ist die Summen-Funktion. Diese Funktion ist für das Addieren von Zahlen verantwortlich.
Die allgemeine Formel für die Funktion sieht so aus:

=SUMME(Zahl1;Zahl2;Zahl3)

Kommen wir zu einem ersten Beispiel.

=SUMME(1;2;3)
//alternative Schreibweise
=SUMME(1+2+3)
Ergebnis: 6

Excel kann mit beiden Schreibweisen etwas anfangen. Um das Ganze flexibler verwenden zu können, können Zellbezeichnungen verwendet werden, wie in diesem Beispiel:

=SUMME(A1;A2;A3;A4)

Eine verkürzte Schreibweise ist folgende Form:

=SUMME(A1:A4)

Hierbei werden nicht alle Zellen angegeben, sondern es wird mit dem Doppelpunkt gesagt, das A1 bis A4 in die Berechnung aufgenommen werden sollen.

Auch wie bei anderen Funktionen, kann man die Summen-Funktion auch kombinieren. Sie kann zum Beispiel dazu verwendet werden um einem Datum eine bestimmte Anzahl von Tagen aufzuaddieren.

=SUMME(JETZT()+7)

Damit haben wir dem heutigen Tag 7 Tage drauf addiert und erhalten als Ergebnis das Datum eine Woche später.

Abrunden-Funktion in Excel

Die Abrunden-Funktion in Excel wird, wie man unschwer erraten kann, zum Abrunden von Kommazahlen verwendet. Die allgemeine Syntax sieht wie folgt aus.

=ABRUNDEN(ZAHL; Anzahl der Stellen)

Fügen wir in diese Platzhalter nun Zahlen ein.

=ABRUNDEN(6,34567;3)

Unsere Kommazahl 6,34567 wird nun auf 3 Stellen hinter dem Komma abgerundet.

Ergebnis:
6,345 //3 Stellen
6,34 //2 Stellen
6,3 //1 Stelle
6 //0 Stellen

Anstatt Zahlen direkt in die Formel einzugeben, können auch einzelne Zellen angegeben werden.

A1 = 5,434565
=ABRUNDEN(A1;4)
Ergebnis: 5,4345

Innerhalb der Abrunden-Funktionen können auch andere Funktionen verwendet werden.
Zum Beispiel die Summen-Funktion.

=ABRUNDEN(SUMME(2+3+5,12345);2)
Ergebnis: 10,12
Impressum | 2014 © Wissen Lernen - Webpixelpromoter.com